Service Notice: Google Slides Signage Issue

Incident Report for Vivi

Update

Our Engineering team continues to investigate the issue affecting Google Slides content in digital signage. Initial analysis is ongoing, and we are reviewing logs and testing to determine the root cause. We understand the impact this may cause and are prioritising the investigation. Further updates will be shared as more information becomes available.
Posted Mar 02, 2026 - 22:59 UTC

Investigating

We are investigating an issue affecting some customers using digital signage that includes Google Slides.

In impacted cases, displays may show the message:
“Parts of this slide didn’t load. Try reloading.”

When this occurs, the signage may not render as expected.

Our Engineering team is actively investigating the root cause and working toward a resolution. We apologize for the disruption and will provide updates as more information becomes available.
Posted Mar 02, 2026 - 15:59 UTC
This incident affects: Backend Services.